阅读 135

Java后端避坑——Spring Boot整合Mybatis之指定Mysql版本

昨天给小伙伴们分享了关于Spring Boot整合shiro时关于导错依赖导致报错问题,有小伙伴留言说解决了他遇到的报错,看到这个我还是觉得蛮开心的。 今天我再来分享一个关于Spring Boot整合Mybatis时碰到的另一个报错问题,也是关于依赖的。好了,不多说了,先看下报的错误:

com.mysql.cj.exceptions.UnableToConnectException: Cannot load connection class because of underlying exception: com.mysql.cj.exceptions.WrongArgumentException: Malformed database URL, failed to parse the connection string near ';characterEncoding=UTF-8'.

还有一个错误提醒是:

com.mysql.cj.exceptions.WrongArgumentException: Malformed database URL, failed to parse the connection string near ';characterEncoding=UTF-8'.

注:运行环境为:IntelliJ IDEA 2018.1.1

一开始以为是application.properties里面的配置写错了,检查了好几遍都没发现问题所在,后面查看pom文件中的依赖,Mysql的依赖也加进来了,问什么还是报错了? 后面通过查看Dependencies里面的版本是8.0.15。

而我电脑里安装的Mysql是5.1.27版本的,Mysql的依赖没有指定版本导致运行的版本与现有的版本不匹配。最后,在依赖里指定Mysql的版本号,问题得以解决。

<dependency>
    <groupId>mysql</groupId>
    <artifactId>mysql-connector-java</artifactId>
    <scope>runtime</scope>
    <version>5.1.27</version>
</dependency>
复制代码

积少成多,滴水穿石!

关注下面的标签,发现更多相似文章
评论