阅读 9

Cannot change version of project facet Dynamic Web Module to 3.0.

使用eclipse创建一个基于maven的web项目。在创建过程中使用了内置的Artifact Id为maven-artchetype-webapp,构建的web版本是2.3。

生成的web.xml文件跟以往的项目不一样。

<!DOCTYPE web-app PUBLIC
 "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
 "http://java.sun.com/dtd/web-app_2_3.dtd" >

<web-app>
  <display-name>Archetype Created Web Application</display-name>
</web-app>复制代码


从已有的项目拷贝过来一份web.xml文件后。发现编译后出现的问题如上。

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
		 xmlns="http://java.sun.com/xml/ns/javaee" 
		 xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" 
		 xsi:schemaLocation="http://java.sun.com/xml/ns/javaee 
		 http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd" id="WebApp_ID" version="3.0">
  <display-name>sshdemo</display-name>
  <welcome-file-list>
    <welcome-file>index.html</welcome-file>
    <welcome-file>index.jsp</welcome-file>
  </welcome-file-list>
</web-app>复制代码

后来找了网络上的解决方案。

只修改web.xml中的头文件是不够的。在工作空间中打开项目.settings目录下的org.eclipse.jdt.core.prefs文件,将1.6改成了1.8(与jdk版本相同)

eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.forbiddenReference=warning
org.eclipse.jdt.core.compiler.source=1.8复制代码

打开org.eclipse.wst.common.component 将project-version="1.6.0"改成1.8.0

<?xml version="1.0" encoding="UTF-8"?><project-modules id="moduleCoreId" project-version="1.8.0">
    <wb-module deploy-name="sshdemo">
        <wb-resource deploy-path="/" source-path="/target/m2e-wtp/web-resources"/>
        <wb-resource deploy-path="/" source-path="/src/main/webapp" tag="defaultRootSource"/>
        <wb-resource deploy-path="/WEB-INF/classes" source-path="/src/main/java"/>
        <wb-resource deploy-path="/WEB-INF/classes" source-path="/src/main/resources"/>
        <property name="context-root" value="sshdemo"/>
        <property name="java-output-path" value="/sshdemo/target/classes"/>
    </wb-module>
</project-modules>复制代码

打开org.eclipse.wst.common.project.facet.core.xml修改jst.web的版本为3.0,修改java版本为1.8

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="jst.web" version="3.0"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
  <installed facet="java" version="1.8"/>
</faceted-project>复制代码

然后再运行项目右键中maven->Update Project


关注下面的标签,发现更多相似文章
评论