阅读 26

通过RVM安装Ruby时报错 "Requirements installation failed with status: 2."

公司配了个新iMac为了安装Cocoapods 更新安装Ruby环境的时候遇到的一个炕, 安装CocoaPods的顺序。

  • 1.先安装rvm rvm是用来管理Ruby版本的工具
  • 2.然后通过rvm安装Ruby
  • 3.通过 Rubygem来安装Cocoapods

问题 1、 Requirements installation failed with status: 2.

1、解决方法

执行 $ rvm get stable

执行 $ rvm list

然后再执行下面命令,记得按回车就是默认安装路径。

$ rvm install "ruby-2.6.3"

看到已经正常开始下载了表示ok了。

关注下面的标签,发现更多相似文章
评论