阅读 327

Flutter插件45.0.1版本卡顿解决方法与Plugin 'Flutter' is incompatible with this install!

昨天将Windows10与MacBook上的AndroidStudio-Flutter插件从44.0.2版本升级到45.0.1版本,之后再切换dart文件时便遇到了无穷尽的卡顿现象。
特别是打开新项目还时常遇到AS假死现象,不能忍啊,只能选择降级Flutter插件版本了。 在操作过程中遇到了版本兼容问题,这里写个笔记记录下来,希望能帮到有需要的朋友。

降级步骤

  1. 首先进入IDEA的插件主页,搜索Flutter。
    搜索Flutter
  2. 进入Flutter插件首页,点击Get蓝色按钮,会有个插件版本列表,分为stable与dev版本,默认是stable。
    • Compatibility with:选择开发设备的IDE版本,是IDEA或者AndroidStudio。
    • 选择想要降级的版本,这里选择44.0.2,注意中间的build兼容版本。如果选择错误,就会出现我遇到的Plugin 'Flutter' is incompatible with this install错误提示。
    • 点击Download按钮,下载插件,一般而言都是.zip格式。
      Flutter主页

      版本选择
  3. 打开IDEA/AndroidStudio->File->Settings->Plugins,点击右上角最右边的设置icon,选择Install Plugin from disk.选择下载的插件文件,重启as。
    安装插件
  4. 应该没45.0.1那么卡了,大功告成。

本方法也适用于其他插件类型的降级。

关注下面的标签,发现更多相似文章
评论