阅读 2163

从Android Studio 开始的ARCore之旅

从Android Studio 开始的ARCore之旅

以下内容译自官方文档,仅供个人学习、记录、参考使用,如有纰漏,还请留言指正。

原文地址:Getting Started with Android Studio

注意:ARCore 目前处于开发预览阶段,相关信息在发布1.0正式版之前或许会有巨大变动。

开发环境配置

  • 安装Android Studio 2.3 及以上版本,搭配Android SDK Platform 7.0 (API等级24) 及以上开发平台
  • 需要一台支持此特性的设备(Google Pixel,Google Pixel XL,三星S8),或见此链接:支持ARCore设备
  • 需要获取给Android Studio 使用的 ARCore SDK,你可以:
    • 下载SDK preview for Android Studio并解压它
      - 或者 -
    • 用以下命令克隆工程项目:
      $ git clone https://github.com/google-ar/arcore-android-sdk.git
  • 需要对在Android 上使用OpenGL 开发有基本了解。如果你对此了解不多,可以查阅以下教程:

打开示例工程

在Android Studio 里,打开在<ARCore SDK Folder>/samples/java_arcore_hello_ar目录下的HelloAR 示例工程。

这个示例工程对特定版本的软件有构建依赖,如Gradle、Android SDK。如果依赖没有安装,Android Studio 会要求你下载并安装这些依赖到本地。

配置你的设备

你必须使用一台受支持的、真实设备。ARCore 并不支持虚拟设备,如Android 模拟器。按如下设置配置你的设备:

运行示例程序

连接Android 设备到开发机上,点击Android Studio 的运行按钮。然后选择Android 设备为部署目标并点击OK。

Android Studio 将你的工程打包成可调试的APK,安装在设备上,并启动应用。有关这个过程的详细信息,参考构建和运行应用一节。

运行应用之后,随着你移动你的设备,应用会自动检测平面,并用菱形格子绘制出来。点击格子可以在表面上放置一个Android 小机器人。

深入学习

阅读示例工程内的代码和注释,以及ARCore的Android SDK 索引文档

之后,你可以以添加依赖的方式集成ARCore 的AAR 库到你的工程里。你的应用的minSDKVersion必须大于等于19。