阅读 973

iOS--Unsupported swift version

最近在项目中集成第三方SDK的时候需要用cocopods集成一个swift库,cocopods安装成功之后打开项目编译运行。双击xcworkspace打开项目之后直接报“unsupported swift version”的错误,如下图:

首先到github上查看了Zip库支持的swift版本,发现swift版本已经更新,并且在podfile中也指定了Zip的最新版本。排除了错误信息提示的swift版本问题。

后来发现是在OC项目中用cocopods安装了swift库,项目中没有指定swift版本的引起的问题。在pods中指定swift版本即可解决问题。

如下图,分别指定项目中swift库的swift版本,注意Pods下面的也需要指定,在未指定之前是Unspecified状态。指定完之后编译即可。