阅读 759

解决gatsby安装失败sharp: Command failed

gatsby是一个基于React和Graphql搭建静态网站的工具,相较于其他的一些静态网站构建工具,他有很多优势,比如:

  1. 静态网站享受webapp的体验同时又能够享受seo
  2. React组件化的开发体验,以及丰富的生态功能
  3. 丰富的数据源,不局限于Markdown
  4. 等等等等...

然而在使用gatsby的过程中常常出现安装错误,最常见的就是使用gatsby-transformer-sharp来处理图片的时候,经常安装失败。

这主要是因为sharp是一个需要同构C构建的模块,而他要下载一个本地模块代码,但是国内的网络导致安装时下载经常会失败,从而导致构建失败,出现:

/Users/Jokcy/projects/9102/blog/node_modules/sharp: Command failed.
复制代码

这样的错误。

那么如何解决呢?很简单,你自己下载他的依赖,然后放到对应的地方就可以了。

  1. 打开这里
  2. 下载你的平台对应的release,比如MAC下载libvips-8.7.4-darwin-x64.tar.gz
  3. 把下载来的文件移动到~/.npm/_libvips下面

然后重新执行安装命令即可。