阅读 646

ant-design-vue按需加载的坑

问题

  • vue-cli4.x中按需加载ant-design-vue,在编译时报错,错误如下

原因

  • ant-design-vue使用less预处理器。在less3.0版本以前,javascriptEnabled属性默认为true,3.0以后默认为false地址
  • 目前项目中less版本为3.0.4,所以在编译中会报错

解决办法

  1. 第一种办法,在vue.config.js中添加如下配置
 css: {
    loaderOptions: {
      less: {
        javascriptEnabled: true
      }
    }
 }
复制代码
  1. 第二种办法就是把less的版本降到3.0以下即可