阅读 19

记一次SVN误删除操作和Tomcat版本与操作系统不兼容 问题分析及解决的过程

前言

1、记录一次 svn实际操作的过程中比较常见问题的分析及解决过程

2、从一个对svn操作还不太熟悉的使用者的角度来分析

3、步骤:发现现象->分析过程(及其中的心里活动)->解决问题

我之前的文章大多都是从发现现象直接到解决问题 ;省略了 分析过程(及其中的心里活动) 所以读者会感觉很“干” 我具体也不太确定这个很干表示什么 可能是都是干货 读起来比较生硬 没有太多的心里活动和个人情感夹杂其中 所以看几眼就不想再看了 除非实际操作起来 真正有用的话 才会从头看到尾;否则 (比如在地铁上或者不想实操 只想随便看看 扩大自己的知识面的时候)真的看不下去 所以现在准备把 分析过程(及其中的心里活动) 这个步骤也加进去

4、导致的效果

1⃣️ 有一些自己的心里活动 读起来可能会感觉有点意思

2⃣️ 太啰嗦了 拐来拐去 尝试了很多错误的方法 最后才达到最终的目标 (自己写的时候 都感觉在浪费文章的字数)

5、结论:有意思的 有必要的 承上启下的 心里活动过程 或 曲折过程 可以写下来;自己都感觉很啰嗦的 那就别写心里活动过程了

复制代码

SVN误删除操作的处理方式

问题现象

图1
图1
有红色标记 说明 该文件夹内部有变动
但该文件夹内部的所有文件都是最新版的并且显示没有变动过
复制代码

分析问题

针对.svn.zip这个文件状态已删除重点说明一下

  • 怎么出现的 (演示下出现的情景)
删除了之后就会出现图1的情况
含义是 本地做了修改 还没有推送到svn远程
复制代码
  • 怎么处理
如果是误删除 那么进行复原(revert)即把这个误操作给还原掉就是回到没有做这个误操作之前的状态
复制代码
  • 类似的情况
此时的状态是丢失 而不是已删除
复制代码
这种情况更新下就行了
复制代码

Mac环境下tomcat版本兼容性问题

问题现象

idea 配置tomcat的时候 报错 说找不到tomcat home
复制代码

问题分析

1⃣️ 版本号是tomcat10 这个高的版本
2⃣️ 既然找不到 那我进入到指定的tomcat目录下 看看是否可以手动的启动tomcat
复制代码
手动启动tomcat报错
接下来我的处理过程开始跑偏了 前方高能预警 请朋友们注意!!!

我应该思考的方向:

这会不会是操作系统(mac)和 tomcat版本不兼容的问题

如果这么思考的话 那么我可能就会想:

去tomcat官网上 符合mac系统的tomcat版本

但偏偏这么想了(导致浪费了一些时间):

我该解决这个报错的异常

复制代码

下面看看我是怎么在错误的方向上尝试的

百度了下有文章说是 文件格式的问题

  • 给startup.sh文件赋予权限
chmod a+x bin/startup.sh
复制代码
  • 修改文件格式
vi bin/startup.sh

:update

:e ++ff=unix

:setlocal ff=unix

:wq

然后启动 此时又出现了其他异常

此时“愚昧”的我才发现了 方向错了

接下来 才将错误的思维扭转

正确的方向:去tomcat官网找mac系统的tomcat版本

复制代码

下载正确的版本

登陆 tomcat 官网

http://tomcat.apache.org/
复制代码

下载tomcat7 版本

这样就可以启动并且也可以在idea中配置tomcat了
复制代码

这里还有一种版本不兼容的情况

下载tomcat10版本 在idea配置tomcat的时候 不可以;tomcat7是可以的 
所以软件不要用最新版本 要用经常长时间检验的稳定的版本、功能比较齐全
复制代码

本文使用 mdnice 排版